Uberspace – Prosody 0.9.10 => 0.9.11

6
992

Seit einiger Zeit betreibe ich meinen eigenen XMPP-Server auf meinem Uberspace. Mittlerweile wird auch dieser Server mit einem Let’s Encrypt Zertifikat verschlüsselt. 

Da ich nun gestern dabei war Roundcube zu aktualisieren

und alles so reibungslos lief, habe ich mich im Nachgang an Prosody gewagt. Hier lief noch die Version 0.9.10.

Zuerst wurde der Service angehalten,

dann die neue Version 0.9.11 installiert

und die Beispiel-Config nach ~/etc/prosody/ verschoben.

Nun musste der Symlink zur Config erneut erstellt werden.

Im Anschluss wurde der Service zu Prosody neu gestartet

und die alte Version 0.9.10 deinstalliert.

Ein abschließender Check zeigt nun aktuelle Version (siehe Screenshot).

Nachtrag

Einige Anpassungen habe ich laut der Anleitung https://0101010.one noch nachgeschoben. Dazu gehören eine neue OpenSSL-Version sowie zwei Anpassungen von Lua.

Check der Version von OpenSSL vorher:

Check der Version von OpenSSL nach der Installation:

Check der Versionen der Lua-Module vorher:

Check der Versionen der Lua-Module nach der Installation:

6 Kommentare

Schreibe einen Kommentar zu Anonym Antwort abbrechen

Bitte bestätige diesen Kommentar!
Bitte den Namen hier eingeben

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.